EL_AN\N Integration Note

Manufacturer: Nuvo
Model Number(s): Grand Concerto
Software 4.0 Build 1452.0 Rel or later
Core Module Versions: 6.0.236 and newer includes zone controller integration only, no virtual

keypads for source control.

Nuvo Grand Concerto FW v2.56, HWv00; M3 Server v1.60, iPod

Comments: v1.53

Document Revision Date: 1/17/2013

OVERVIEW AND SUPPORTED FEATURES

THE FOLLOWING FEATURES ARE SUPPORTED:

Traditional Whole-House Audio: The Grand Concerto six-source eight-zone Audio Zone Controller has
keypads in each zone that control the volume and source.

Support for IR: The Grand Concerto has IR outputs that can provide signals to each of the sources,
enabling transport control (Play, Pause, Stop, etc) for equipment that has IR control. The Grand Concerto
has a built-in library of existing codes, as well as the ability to learn codes. These codes are supported
through the Virtual Concerto ControlPad in the g! system.

Support for AM/FM Radio: The Nuvo T2 AM/FM/XM tuner is supported either through direct two way
serial communication using the ELAN tuner interface or through the NuvoNet network using the interface
from a Virtual Concerto ControlPad in the g! system.

Display: The Concerto ControlPad keypads have a display that normally shows the name of the source,
volume level etc. When playing audio from the g! system, the track information is displayed.

Multiple Chassis: The Nuvo Expansion Chassis is supported for a total of 16 audio zones.

THE FOLLOWING FEATURES ARE NOT SUPPORTED:

Virtual Keypads for source control (v6): source control via virtual keypads is not supported in version
6.0.

Virtual Concerto ControlPad Limitation: The Nuvo Grand Concerto systems are designed for a
maximum of 20 Nuvo ControlPads. The ControlPads are typically addressed to a zone number 1 thru 16.
g! Virtual ControlPads start at address 20 and are dynamically addressed down from 20 as required. If
there is an address conflict between a g! Virtual ControlPad and a Nuvo physical ControlPad there will be
issues with control from those ControlPads. In a typical 16 zone system this means that there can only be
a maximum of 4 g! Virtual ControlPads active at any one time.

IR Through Custom Interfaces: The g! system cannot send IR commands to the Grand Concerto
through Event Mapping. IR can only be sent using the Virtual Concerto ControlPad.

OSD/HR2/TS2 Controllers: The g! software On-Screen Display, HR2 and the TS2 WILL NOT
FUNCTION CORRECTLY with this zone controller’s source devices and is specifically NOT supported.

Source control in an “output from zone” configuration: virtual keypads for source control will not
work unless they are directly in a Russound zone. They will not work when a zone from Russound is
configured as a source in another zone controller.

Any feature not specifically noted as supported should be assumed to be unsupported.
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VIEWER INTERFACE FOR NUVONET SOURCES

The interface shown on the Viewer for sources to a Grand Concerto depends on the source type.

For Nuvo sources with standard two-way serial control, the g! interface for the device will be
displayed.

For NuvoNet sources not controlled by RS-232 connections such as the NV-M3 3-Source Music
Server or the NV-RIPD IPOD dock, the display will resemble the Concerto ControlPad interface and
two-way feedback will be provided by the Grand Concerto.

Note: Use of a virtual keypad when connecting to the Nuvo via SerialBrick is not supported at this time.

INSTALLATION OVERVIEW

1.

During the rough-in phase, install speaker wire for the speakers and Cat5 cable for keypads, in each
zone.

Also during the rough-in phase, run a Cat5 wire from the location of the Grand Concerto back to the
Network Assembly of the ELAN system for RS-232 communications. Refer to the RS-232
Connection Options Integration Note for other options.

Mount the speakers and keypads in each zone, and install the Grand Concerto and the sources.

Program the Grand Concerto using the NV-18G NV-E6G Configurator. This includes setting the
number of sources, the names and input numbers for each source, and the zones. See the Grand
Concerto Programming section for more information.

Test the entire Grand Concerto system to ensure that all the sources play correctly in every zone,
and that the keypad buttons behave correctly from the keypads.

If the system includes one or more NuvoNet device (such as the NV-M3 Music Server), they should
be connected to the Grand Concerto with NuvoNet according to the standard Nuvo procedure.

Connect the g! system to the Grand Concerto system electrically. See the wiring diagrams for more
information.

Configure the g! system for the Grand Concerto and confirm communication between the Grand
Concerto and the g! system controller.

Test the system by changing sources in a zone to confirm the correct source plays, and by testing the
g! interface transport control and media server controls.
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CONNECTION DIAGRAMS
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# Device M anufacturer Part Number Protocol Connector Type Notes
2 |g!System Controller ELAN Various (e.g. HC12) RS-232 RJ-45 Female
3 |Cat5 Cable Assy. Installer N/A RS-485,RS-232 |RJ-45Male X Punch Down
4 |RCA Cable Any N/A Analog RCA XRCA
5 |Speakers Any N/A Analog Wire
6 |Speaker Cable Any N/A Analog Wire
7 |Nuvo Concerto EZ Port Nuvo NV-BGEZP NuvoNet RJ-45Male X RJ-45 M ale
8 |Nuvo Concerto ControlPad Nuvo NV-18GCP NuvoNet RJ-45Male XRJ-45 M ale
9 |DB9M to RJ45 Adapter ELAN HA-CB-307 RS-232 DB-9 Male X RJ-45 Female
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GRAND CONCERTO PROGRAMMING

Once the equipment is installed and connected you must program the Grand Concerto using the Nuvo
Configurator Software according to Nuvo guidelines. Special steps that relate to g! are provided below.

Note: The g! software will not read source and zone information from the Grand Concerto. Source and
Zone information must still be added manually in the g! Configurator.

SOURCE INPUTS:

The source input devices set up in the Nuvo Grand Concerto Configurator must match the Grand
Concerto’s source set up in the g! Configurator, as well as the physical connections to the Grand
Concerto itself.

N¥-I8G & N¥-E6G Configurator — HL_test v14 (N¥-E6G) (Modified) — |EI|1|

File Miew Help

Start I IF Library ~ Sources I Macmsl Zonesl Syztem Settingsl Update S_l,lsteml

# | Make | adel | Type | Dizplay String | Gain |
1 MHuvo MW-T2DFG (&) Tuner Tunerl +10.00 dg
2 Muvo MY-T 200G (B) Turer Tuner2 +10.00 48
3 MHuvo M-b 3 (4] Mugic Server P31 +10.00 dg
4 Muvo M43 [B] Music Server MP3 2 +10.00 48
b MNuvo WY-RIPS Mugic Server iPod +10.00 dB
E  Generic Generic Generic MP3 +10.00 48

Select I Clear Capy From. .

< Back MHext >

Add sources to the Grand Concerto in the Nuvo software by choosing the source tab, then selecting the
input number and clicking the select button.
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Select Source x|

Source: I'I
Drizplay MName: I Gain
Short Name:IFM

Caompanent:

= Nuva ;I
o MR T [A)

- M-I [B]

- M3 C)

o PR J I +10.00 dB
- MW-RIPS

- MW-T2DFG [A)

- MY-T20FG (B]
- MW-T20HG (&) LI

[~ By Type

Cancel |

[ Alwayz use Dizplay Mame [ignore name sent by Mulfolet device]

Fill in the Display Name and Short Name for the source, then choose the nearest match for the
component from the component list. The Gain can also be set here for input level matching. Click OK,
and repeat for each additional source.

ZONE OUTPUTS

Configure the Zone Outputs in the Nuvo software by selecting the Zones tab, then choose the same
number to be configured and click the “Edit” button.

51
Drescription: Slave Tar |[Mone| | Slave ED Setings
—Walumne —EQ Settings
Initial Max Party Page Balance BassEQ Tiebls EQ

L[ L =E

| e0d8 | o [ G0 | S0de | Center [ o | o
olurne Reset at Zone v Loudness compensation
I~ Volume A Zane ON ¥ Loud ion ON
W] ettt saniee ma Do-Mot-Disturb Display Settings
™ Mo Mute Bright d

™ Lock zone by default I J
[RErsbed =] I” Mo Page |AutoDim Disabled =
IND Source Groping > I Mo Party IAutDDlm Brightness OfF j
Enabled Soures I~ | Display Time while zane off

¥ Source 1 ¥ Source 2 v Source 3

¥ Source 4 v Source 5 v Source B

Fill in the Zone Description and make any adjustments to the sound and keypad levels that are
necessary.

CONFIGURING THE g! SOFTWARE

SETTING UP THE GRAND CONCERTO:

In the g! Configurator, select the Media tab. Add the Communication Device for the Grand Concerto
using Serial Port/ Standard Connection. Add the Grand Concerto itself as an Audio Zone Controller and
select the Communication Device added in the last step.
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SETTING UP NUVONET DEVICES

Certain Nuvo Devices, such as the NV-M3 Music Server and the NV-RIPD IPOD dock, communicate
directly with the Grand Concerto using NuvoNet, bypassing the g! system. These devices can still be
controlled and provide the g! software with feedback by configuring g! to emulate an Grand Concerto
ControlPad. Follow the steps below to set up this feature. These devices will not use the standard g!
interfaces. The emulation imitates a NuvoNet Keypad.

Note: When setting up keypads to control Nuvo sources, you must create a keypad for each source.

ADDING A KEYPAD:

Add the Grand Concerto ControlPad in the Media tab by right clicking “Keypads and Interfaces” and
choosing the “Add New Interface” option. Type a name for the keypad in the space provided. Leave
“Create from Template” set to <NONE>, and choose <ACTIVE ZONE HANDLER> from the “Connect to

Device” drop-down.
x

Interface Name I Muwo Dock

Create From Template Ic: HONE = j

Connectto Device  |< ACTIVE ZONE HANDLER > |»|

Cancel 0K

Click the “+” to the left of the new keypad interface to expand the view and show the available layouts.
Click the Large Format> Large Landscape(Standard) option to display the blank interface page.
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Right-click anywhere in the black field on the right and choose “Add New Control”. From the list, choose

“Audio Zone Keypad*:

M Bedroom TV
B Theater TV
I IR Display
I Projector
Keypad Controllers
[=] B= Audio Zone Controllers
[5] == ELAN MB86A (6 Zone)
= Sources
i} Zones
[5] B Elan V85 (8 Zones)
= Sources
i} Zones
[5] == Sunfire TGR-401, TGP-401
= Sources
j Zones

EE Generic Single Zone Controller | —

[=] == ADA Suite 8100
= Sources
i} Zones
[E] E Keypads and Interfaces
Living Room: Settings
Cable TV
Blu-Ray Changer
Cable DVR
DVD Changer
Theater: Settings
= Nuva Dack
B Large Format
E Small Format
B 152
E HR2
E Zone Headers
B Interface Templates
= Interface Groups
Home
Bar

Interface Layout - Nuvo Dock

Add New Control

Mame Audio Zone Keypad

Control Type

Audio Button

Audio Keypad

Audio Keypad Text Views
Avudio Made Cortrol
Audio Sound Adjust

g cl
Buttan (Momentary)
Button (Standard)
Button (Toggle)
Calendar

Clock (Date Cnly)
Clock (DatesTime)
Clock (Time Only)
Composite Yideo

Frmmp | el

W

Cancel | OK |

LARGE LANDSCAPE (STANDARD!

Click the small blue box that was added to turn the boarder yellow and allow resizing. Stretch the edges
of the box to mostly fill the page. As always, leave a slight border around controls on a custom interface.

7 of 11



Interface Layout - Nuvo Dock

LARGE LANDSCAPE (STANDARD) LARGE LANDSCAPE (WIDE) LARGE PORTRAIT (STANDARD)

In the Audio Zone Keypad Properties window, select the text size drop down and choose “Auto” from the
top of the list. Copy the completed interface to all other resolution settings that will be used in the system.

Audio Zone Keypad Properties

R I Audio Zone Keypad Ficture. .
Text Colar _ Select Colar .. | [~ Use Default
Face Calor _ Select Color. | W Use Defautt

[ Transparent (Reguires Backoround Texture)
Drefault

l

Fadiuz

i
Shading j | Defaut
Shading J' w
Style I j Border INnne j
Text Size mign | |
Text Gualty [Defaut | Funct. | =
Connect To ] j

Note: The Audio Zone Keypad can be copied into other formats to appear on touch screens using other
resolutions. To copy the keypad to another “Large Format” resolution, simply right-click in the thumbnail
at the bottom of the screen and select Copy Layout. Then, click the thumbnail for the new resolution,
right-click and select Paste Layout.

LARGE LANDSCAPE (STANDARLY] LARGE |
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To copy the keypad to another format, right-click the new format type in the system tree, and then select
COPY LAYOUT FROM...

= Nuvo Dock
Large Format
Small Forrg Ll =

B 152
HR2 Add Mew Page. ..

Map/Remap Interface to Device. ..

Zone HeadersjE=EEls RS
Move Up
Maove Down

Interface Tem

Interface Grol
Home C sout From LARGE F
Bar

Since the Audio Zone Keypad automatically maps to Active Zone Handler, there is no need for further
programming.

Next, add the keypad as a source to your Grand Concerto in place of any sources controlled by the
NuvoNet. Choose an Icon for the source, and change the Display Name to reflect the nature of the
source:
B Theater TV
M IR Display

L _PmJECtm System # [21361]
Keypad Controllers

=] B Audio Zone Controllers

B ELAN M86A (6 Zone)
E= Elan V85 (8 Zones) Display Icon

Audio Source: Interface: Nuvo Dock

Source Device |Interface: MNuwa Dock

E= Sunfire TGR-401, TGP-401

EE Generic Single Zone Controller : )
EE ADA Suite 8100 Source Volume <oonToHANGE: 4]
[=] == Nuvo Grand Concerto (8 zone) Display Name Nuvo Dock

[E] = Sources
= (IN 1) Interface: Nuvo Dock
= (N2

IMPORTANT! Source Input must match input programmed into Nuvo.
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g! CONFIGURATION DETAILS

The following table provides settings used in the g! Configurator when connecting to a Grand Concerto system. Please refer to the g! Configurator
Reference Guide for more details.

In the table below:

o “<Select>”

0 “<User Defined>", etc.

Select the appropriate item from the list (or drop-down) in the Configurator.

Type in the desired name for the item.

Devices Variable Name Setting Comments
Communication Devices |Name <User Defined> (Default: Nuvo Grand Concerto)
Type Serial Port

Communication Type

Standard Connection

Location <User Defined> (Not Required)
Com Port <Select>
Audio Zone Controllers [Name <User Defined> (Default: Nuvo Grand Concerto (8 Zone)) |Select 8 or 16 zones as appropriate.
Device Type Nuvo Grand Concerto (8 Zone)
Location <User Defined> (Not Required)

Comm Device

<Select> (Default: Nuvo Grand Concerto)

Sources Name <User Defined>
Source Device <Select> <User Defined>
Source Volume <Select>
Show Source <Select>
Zones Name <User Defined>
Show Zone <Select>

Keypads and Interfaces

Add a keypad and a control for an Audio Zone Keypad

10 of 11




COMMON MISTAKES

1.

Improper programming of the Grand Concerto. Make sure you complete programming of the Nuvo
equipment, and that it functions properly as a stand-alone system, before attempting to connect and
control from the g! system.

Source number mismatch from Nuvo configuration to Configurator. Make sure that the source input
configuration is the same in Configurator as in the Nuvo configuration to ensure the keypads in g!
match the source selected on the Nuvo.

(I.E. Nuvo config: source 1 AM/FM; g! config: source 1 AM/FM)

ControlPad address conflict. If there are any address conflicts between Nuvo ControlPads and g!
Virtual ControlPads there will be issues with control from those ControlPads. For example: in a
typical 16 zone system with 16 Nuvo ControlPads, a maximum of 4 g! Virtual ControlPads can be
used simultaneously without causing a conflict. This is due to the maximum number of 20
ControlPads (16 Nuvo + 4 g! = 20 Max).

Not adding a virtual keypad for each NuvoNet source. Each NuvoNet source (iPod dock, M3 server
etc.) must have its own keypad configured for source control.
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